<!doctype html>
<html lang="en-US">

<head>
        <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="https://gmpg.org/xfn/11">
    <!-- Favicons -->
    <link rel="apple-touch-icon" sizes="180x180" href="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/favicon/favicon-black.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/favicon/favicon-black.png">
    <link rel="icon" type="image/png" sizes="16x16" href="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/favicon/favicon-black.png">
    <link rel="manifest" href="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/favicon/site.webmanifest">
    <link rel="mask-icon" href="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/favicon/favicon-black.png" color="#0d6efd">
    <meta name="msapplication-TileColor" content="#ffffff">
    <meta name="theme-color" content="#ffffff">

    
        <script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "BreadcrumbList",
            "itemListElement":
            [{
            "@type": "ListItem",
            "position": 1,
            "name": "Eagles",
            "item": "https://www.sportstalkphilly.com/eagles"
            },{
            "@type": "ListItem",
            "position": 2,
            "name": "Eagles-Wentz Faceoff Goes To The Birds"

                        }]
        }
    </script>
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v18.5 (Yoast SEO v19.4) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Eagles-Wentz Faceoff Goes To The Birds - sportstalkphilly - News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers</title>
	<link rel="canonical" href="https://www.sportstalkphilly.com/2022/09/eagles-wentz-faceoff-goes-to-the-birds.html" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Eagles-Wentz Faceoff Goes To The Birds" />
	<meta property="og:description" content="The Eagles defense destroyed their former QB in their Week 3 match-up." />
	<meta property="og:url" content="https://www.sportstalkphilly.com/2022/09/eagles-wentz-faceoff-goes-to-the-birds.html" />
	<meta property="og:site_name" content="sportstalkphilly - News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers" />
	<meta property="article:published_time" content="2022-09-25T20:13:53+00:00" />
	<meta property="article:modified_time" content="2022-09-25T20:34:10+00:00" />
	<meta property="og:image" content="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="533" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Paul Bowman" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@PhillyBallPaul" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Paul Bowman" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//www.sportstalkphilly.com' />
<link rel='dns-prefetch' href='//stackpath.bootstrapcdn.com' />
<link rel="alternate" type="application/rss+xml" title="sportstalkphilly - News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers &raquo; Feed" href="https://www.sportstalkphilly.com/feed" />
<link rel="alternate" type="application/rss+xml" title="sportstalkphilly - News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers &raquo; Comments Feed" href="https://www.sportstalkphilly.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="sportstalkphilly - News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers &raquo; Eagles-Wentz Faceoff Goes To The Birds Comments Feed" href="https://www.sportstalkphilly.com/2022/09/eagles-wentz-faceoff-goes-to-the-birds.html/feed" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='newfaq-content-frontend-css'  href='https://www.sportstalkphilly.com/wp-content/plugins/faq-content-webnow/newfaq-dist/blocks.style.build.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='finixio-mega-menu-bootstrap-styles-css'  href='https://stackpath.bootstrapcdn.com/bootstrap/4.3.1/css/bootstrap.min.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='finixio-mega-menu-styles-css'  href='https://www.sportstalkphilly.com/wp-content/plugins/finixio-mega-menu/assets/css/finixio-mega-menu-styles.min.css?ver=2.0.34' type='text/css' media='' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.sportstalkphilly.com/wp-content/themes/bootscore-main/style.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/css/lib/bootstrap.min.css?ver=202207121015' type='text/css' media='all' />
<link rel='stylesheet' id='slick-style-css'  href='https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/css/slick.css?ver=6.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootscore-style-css'  href='https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/style.css?ver=202208220746' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://www.sportstalkphilly.com/wp-content/themes/bootscore-main/css/lib/fontawesome.min.css?ver=202203151447' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/themes/bootscore-main/js/nofollow-attr-support.js?ver=6.0.1' id='js-file-js'></script>
<link rel="https://api.w.org/" href="https://www.sportstalkphilly.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.sportstalkphilly.com/wp-json/wp/v2/posts/24559" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sportstalkphilly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sportstalkphilly.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.1" />
<link rel='shortlink' href='https://www.sportstalkphilly.com/?p=24559' />
<link rel="alternate" type="application/json+oembed" href="https://www.sportstalkphilly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sportstalkphilly.com%2F2022%2F09%2Feagles-wentz-faceoff-goes-to-the-birds.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sportstalkphilly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sportstalkphilly.com%2F2022%2F09%2Feagles-wentz-faceoff-goes-to-the-birds.html&#038;format=xml" />
<!-- / HREFLANG Tags by DCGWS Version 2.0.0 -->
<!-- / HREFLANG Tags by DCGWS -->
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-M3J79WM');</script>
<!-- End Google Tag Manager --><link rel="pingback" href="https://www.sportstalkphilly.com/xmlrpc.php"><link rel="icon" href="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/favicon-black-148x150.png" sizes="32x32" />
<link rel="icon" href="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/favicon-black.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/favicon-black.png" />
<meta name="msapplication-TileImage" content="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/favicon-black.png" />
</head>

<body class="post-template-default single single-post postid-24559 single-format-standard wp-custom-logo">
    
    <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M3J79WM"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>
  <div id="to-top"></div>

  <div id="page" class="site">

    <header id="masthead" class="site-header">

      <div class="fixed-top bg-white">
      
		<div id="wrapper-navbar" class="insidebitcoinsMegaNav" itemscope itemtype="http://schema.org/WebSite"
		 class="header-box-shadow">
          <div class="container">

			 <div class="row align-items-center header">
				<div class="col-4 col-lg-4 header-logo d-none d-lg-block">
					<a href="https://www.sportstalkphilly.com/" class="navbar-brand" rel="home"><img width="415" height="191" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/logo-new-1.jpg" class="custom-logo" alt="sportstalkphilly &#8211; News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers" srcset="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/logo-new-1.jpg 415w, https://www.sportstalkphilly.com/wp-content/uploads/2022/07/logo-new-1-300x138.jpg 300w" sizes="(max-width: 415px) 100vw, 415px" /></a>				</div>

				<div class="col-8 col-lg-8 header-right main-nav-col d-none d-lg-block">
					<div class="header-right-inner d-flex align-items-center justify-content-end">
						<nav class="main-nav nav d-lg-inline">
							<ul id="menu-top-menu" class="nav-list c-megaMenu"><li class="c-megaMenu--menu-item " id="menu-1"><a class="noLink-a-has-mega-menu" href="https://www.sportstalkphilly.com/eagles">Eagles</a></li><li class="c-megaMenu--menu-item " id="menu-2"><a class="noLink-a-has-mega-menu" href="https://www.sportstalkphilly.com/flyers">Flyers</a></li><li class="c-megaMenu--menu-item " id="menu-3"><a class="noLink-a-has-mega-menu" href="https://www.sportstalkphilly.com/phillies">Phillies</a></li><li class="c-megaMenu--menu-item " id="menu-4"><a class="noLink-a-has-mega-menu" href="https://www.sportstalkphilly.com/sixers">Sixers</a></li></ul>						</nav>
													<div class="header-telegram-outer">
											<div class="textwidget"><div class="header-telegram-btn"><a href="https://t.me/sportstalkphilly" target="_blank" rel="noopener"><span class="telegram-btn-text">TELEGRAM</span><span class="telegram-btn-img"><img width="22" height="19" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/08/telegram-button.svg" /></span></a></div>
</div>
									</div>
						
						<!-- <div class="header-right-icons">-->
							<!-- Country Dropdown -->
						<!-- < ?php
							include_once( WP_PLUGIN_DIR .'/finixio-mega-menu/library/components/mega-menu-component/country-flag-dropdown.php');
						?>-->
						<!-- </div>-->
					</div>
				</div>
			</div>
		</div>

				<nav class="navbar navbar-light bg-light d-block d-lg-none">
					<div class="megaMenu--mobile-header">
					
						<!-- Your site title as branding in the menu -->
						<a href="https://www.sportstalkphilly.com/" class="navbar-brand" rel="home"><img width="415" height="191" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/logo-new-1.jpg" class="custom-logo" alt="sportstalkphilly &#8211; News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers" srcset="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/logo-new-1.jpg 415w, https://www.sportstalkphilly.com/wp-content/uploads/2022/07/logo-new-1-300x138.jpg 300w" sizes="(max-width: 415px) 100vw, 415px" /></a>						
						<!-- Country Dropdown
						< ?php
							include( WP_PLUGIN_DIR .'/finixio-mega-menu/library/components/mega-menu-component/country-flag-dropdown.php');
						?> -->
						<button class="navbar-toggler" type="button" id="navbar-toggler">
							<span class="navbar-toggler-icon">
								<i class="fa fa-bars"></i>
							</span>
						</button>
												<div class="header-telegram-outer">
										<div class="textwidget"><div class="header-telegram-btn"><a href="https://t.me/sportstalkphilly" target="_blank" rel="noopener"><span class="telegram-btn-text">TELEGRAM</span><span class="telegram-btn-img"><img width="22" height="19" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/08/telegram-button.svg" /></span></a></div>
</div>
								</div>
											</div><!--/.megaMenu--mobile-header-->
					<div id="navbarNavDropdown">
						
<!--<ul class="navbar-nav">-->
<!--    <li class="nav-item dropdown">-->
<!--        <a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">-->
<!--            Dropdown link-->
<!--        </a>-->
<!--        <div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">-->
<!--            <a class="dropdown-item" href="#">Action</a>-->
<!--            <a class="dropdown-item" href="#">Another action</a>-->
<!--            <a class="dropdown-item" href="#">Something else here</a>-->
<!--        </div>-->
<!--    </li>-->
<!--    <li class="nav-item">-->
<!--        <a class="nav-link" href="#">Pricing</a>-->
<!--    </li>-->
<!--    <li class="nav-item dropdown">-->
<!--        <a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">-->
<!--            Dropdown link-->
<!--        </a>-->
<!--        <div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">-->
<!--            <a class="dropdown-item" href="#">Action</a>-->
<!--            <a class="dropdown-item" href="#">Another action</a>-->
<!--            <a class="dropdown-item" href="#">Something else here</a>-->
<!--        </div>-->
<!--    </li>-->
<!--</ul>-->


<ul class="navbar-nav">

                    <li class="nav-item">
                    <a class="nav-link" href="https://www.sportstalkphilly.com/eagles">
                        Eagles                    </a>
                </li>
                            <li class="nav-item">
                    <a class="nav-link" href="https://www.sportstalkphilly.com/flyers">
                        Flyers                    </a>
                </li>
                            <li class="nav-item">
                    <a class="nav-link" href="https://www.sportstalkphilly.com/phillies">
                        Phillies                    </a>
                </li>
                            <li class="nav-item">
                    <a class="nav-link" href="https://www.sportstalkphilly.com/sixers">
                        Sixers                    </a>
                </li>
              
</ul>
<!-- Country Dropdown -->
<div class="fin-country-dropdown">
    <div class="dropdown">
            </div>
</div>
</div><!--/.fin-country-dropdown-->
						<!-- < ?php
						include_once( WP_PLUGIN_DIR .'/finixio-mega-menu/library/components/mega-menu-component/country-flag-dropdown.php');
						?>-->
					</div>
				</nav>

		  
          </div><!-- wrapper -->


      </div><!-- .fixed-top .bg-light -->

    </header><!-- #masthead -->
<div id="content" class="site-content container">
  <div id="primary" class="content-area">

    <!-- Hook to add something nice -->
    
    <nav class="breadcrumbs small rounded post-has-image"><div class="d-none d-lg-block"><a style="color: #060606" href="https://www.sportstalkphilly.com/">Home</a><span class="divider">&#10095;</span><a href="https://www.sportstalkphilly.com/eagles">Eagles</a> <span class="divider">&#10095;</span> <span class="breadcrumb_last">Eagles-Wentz Faceoff Goes To The Birds</span></div><div class="d-lg-none"><span class="divider">&#10095;</span><a href="https://www.sportstalkphilly.com/eagles" rel="category tag">Eagles</a> <span class="divider">&#10095;</span> <a href="https://www.sportstalkphilly.com/news" rel="category tag">News</a> <span class="divider">&#10095;</span> <a href="https://www.sportstalkphilly.com/writer-paul-bowman" rel="category tag">Writer: Paul Bowman</a></div></nav>
    <div class="row">
      <div class="col-xl-8 content-area-with-sidebar">

        <main id="main" class="site-main">
          <div class="entry-header mt-3">
                        <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge oval-badge bg-light text-black text-decoration-none">Eagles</a></div>            <h1>Eagles-Wentz Faceoff Goes To The Birds</h1>                <div class="entry-meta custom-author row">
                <div class="col-12 col-md-6 author-info">
            <div class="row">
                <div class="col-4 author-avatar 278">
                    <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' loading='lazy'/>                </div>
                <div class="col-8">
                    <div class="row">
                <div class="col-12 author-name">
                    <a href="https://www.sportstalkphilly.com/author/paul-bowman">
                        <h5 class="verified">Paul Bowman</h5>
                    </a>
                </div>
                <div class="col-12 author-social">
                            <a href="https://twitter.com/PhillyBallPaul" rel="nofollow" target="_blank">
        <i class="fab fa-twitter"></i>
    </a>
                                </div>
                <div class="col-12 post-date">
                    <time datetime="2022-09-25T15:34:10Z">September 25 2022</time>
                </div>
            </div>
                </div>
            </div>
        </div>
        <div class="col-12 col-md-6 text-end social-icons">
            
    <div class="btn btn-light btn-discl" data-bs-toggle="tooltip" data-bs-placement="bottom" title="">
        <span>Disclosure</span>&nbsp;&nbsp;<img width="15" height="15" src="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/icons/disclosure.svg">
    </div>
                                <a class="btn btn-light btn-share addthis_button_expanded" href="" target="_blank" rel="nofollow">
            <span>Share</span>&nbsp;&nbsp;<img width="13" height="15" src="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/icons/share.svg">
        </a>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js"></script>
            </div>
    </div>
                
      <div class="post-thumbnail">
        <img width="800" height="533" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1.jpg" class="rounded wp-post-image" alt="" srcset="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1.jpg 800w, https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1-300x200.jpg 300w, https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1-768x512.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" />      </div><!-- .post-thumbnail -->

              </div>

          <div class="entry-content">
            <div class="telegrame_cta_content"><div class="wrap"><div class="telegrame_cta_content_inr"><p>Join Our <a href="https://t.me/sportstalkphilly" target="_blank" rel="noopener">Telegram </a>channel to stay up to date on breaking news coverage</p>
</div></div></div>
<p>The undefeated Eagles, with wins over <a href="https://www.sportstalkphilly.com/2022/09/eagles-fly-away-with-win-over-lions.html" target="_blank" rel="noreferrer noopener">the Lions</a> and <a href="https://bit.ly/3xFtMAL" target="_blank" rel="noreferrer noopener">the Vikings</a>, came more than ready to play on the defensive side of the ball in this one to secure the team&#8217;s third win of the season.</p>



<p>Looking to take advantage of the issues former-Eagle Carson Wentz has holding onto the ball, an issue that Eagles fans and players know all to well, the front four feasted early on with four sacks in the first quarter alone. Sacks and tackles for loss were coming to the team regularly, especially when a fifth rusher was added to the mix.</p>



<p>The offense was a different story. A questionable catch (which the Eagles offense successfully hurried up to prevent review of) lead to the Eagles getting down the field where they stalled for just a field goal. Otherwise, the Commanders keyed on Hurts running and Hurts did a poor job throwing, throwing into coverage and forcing the receivers to play defensive back themselves rather than throwing the receiver open by throwing to the outside or deeper.</p>



<p>While Hurts didn&#8217;t improve to the level of his performance last week, he did gradually improve in the second quarter while the defense maintained the pressure to put the team in position to win at the half. He barely got a chance to throw in the conservative offense that was on the field in the second-half, however.</p>



<p>The second half really mirrored last week &#8211; the offense was terribly conservative and so drives went nowhere. The defensive play calling really took it&#8217;s foot off the gas at times and allowed Washington to move the chains. At least the defense did bring pressure occasionally in that quarter, something the offense never did.</p>



<p>Despite the offensive struggles, however, that one 24-point quarter was all that the Eagles defense needed to pull out the win, limiting Washington to 8 points and leaving Carson Wentz and his crew in a state of embarrassment. </p>



<p>The Eagles advance to 3-0 to remain undefeated. With Kansas City losing to the Colts and one of the Bills or Dolphins having to lose (or at least tie today) the Eagles are in increasingly little company in that regard. Also remaining undefeated, at least for now, are the Giants (MNF) and the Buccaneers (4:25 game). </p>



<hr class="wp-block-separator has-alpha-channel-opacity"/>



<p><strong>Offensive MVP: </strong>DeVonta Smith</p>



<p>Hurts was not particularly sharp to start today, but Smith did what he could to help him out and keep the offense moving. Of course, he had that deep questionable catch to setup the team&#8217;s first points, but also two incredible high-points to setup the Birds at the one-yard line and then catch the touchdown to end the first half. He wound up with 169 yards and a touchdown on eight catches in this contest.</p>



<hr class="wp-block-separator has-alpha-channel-opacity"/>



<p><strong>Defensive MVP: </strong>Brandon Graham</p>



<p>While Fletcher Cox and Josh Sweat also feasted on Wentz today, but it was Graham that managed the most tackles (six) and forced a fumble that setup the Eagles first touchdown of the game.  He also registered a team-high 2.5 sacks. Graham is a player who it feels like many fans have written off because of his age following basically an entire season that was lost to injury, but he was incredibly productive again this week and figures to continue to be as long as the Eagles rotate him enough to keep him fresh throughout the year.</p>



<hr class="wp-block-separator has-alpha-channel-opacity"/>



<p><strong>Game Notes</strong></p>



<ul><li>Washington was obviously keyed on Hurts running and Hurts was bad passing, so it&#8217;s amazing that the play calling simply didn&#8217;t move to more screens and runs. The Eagles scored an easy touchdown on their first screen and Sanders was averaging 4 yards. If our offensive coordinator is so amazing, the adjustments to make in play calling are not that difficult to identify.</li><li>Similarly, the offense was once again non-existent in the second half. If adjustments are supposedly being made, how does the team get worse after the half. Clearly, there&#8217;s a problem &#8211; whether that be an OC who&#8217;s afraid to call aggressive plays when he&#8217;s up or just a flat out awful play-caller.</li><li>Related to the highly conservative offensive play calling is a defensive coordinator that seems to take the pedal off the gas in the fourth quarter and call coverage that allows offenses to move the chains. The two together are no recipe for success if the Eagles want to go deep into the playoffs.</li><li>Landon Dickerson was on the bench at the half with Sua Opeta filling in at guard. Dickerson was questionable heading into this game, so maybe the Birds figured they&#8217;d try to rest him with a 3-score lead (including 2-point conversions), but it will be something to monitor going forward.</li><li>Darius Slay missed some snaps again with a back issue, but returned to the game.</li><li>Dallas Goedert left the game with a shin injury, giving rookie Grant Calcaterra his first snaps in the NFL. Calcaterra made a 40-yard catch and run, but Goedert did return to the game later on.</li><li>Haason Reddick limped off the field in the fourth quarter after getting rolled up on. He did return to the game later on, so hopefully it is not much of a concern going forward.</li><li>A dumb penalty on Jordan Davis during the field goal by Washington resulted in a free set of downs for Washington. It&#8217;s a really stupid penalty and while the defense wound up making a goal-line stand, it wound up resulting in a safety (the Eagles got the ball at the half-yard line to start the next drive), so it gave the Commanders their first points as well as the ball back for offense.</li></ul>



<hr class="wp-block-separator has-alpha-channel-opacity"/>



<h2 id="h-philadelphia-eagles-at-washington-commanders-september-25-2022">Philadelphia Eagles at Washington Commanders – September 25, 2022</h2>



<figure class="wp-block-table"><table><tbody><tr><td><strong>Team</strong></td><td><strong>Q1</strong></td><td><strong>Q2</strong></td><td><strong>Q3</strong></td><td><strong>Q4</strong></td></tr><tr><td><strong><strong><strong><strong><strong>Philadelphia</strong></strong></strong></strong></strong></td><td>0</td><td>24</td><td>0</td><td>0</td></tr><tr><td><strong><strong><strong>Washington</strong></strong></strong></td><td>0</td><td>0</td><td>0</td><td>8</td></tr></tbody></table></figure>
<div class="telegrame_cta_content"><div class="wrap"><div class="telegrame_cta_content_inr"><p>Join Our <a href="https://t.me/sportstalkphilly" target="_blank" rel="noopener">Telegram </a>channel to stay up to date on breaking news coverage</p>
</div></div></div>          </div>

          <div class="entry-footer clear-both">
            <div class="row">
              <div class="col mb-4">
                  <small>Topics</small> &nbsp; <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge oval-badge bg-light text-black text-decoration-none">Eagles</a> <a href="https://www.sportstalkphilly.com/news" class="badge oval-badge bg-light text-black text-decoration-none">News</a> <a href="https://www.sportstalkphilly.com/writer-paul-bowman" class="badge oval-badge bg-light text-black text-decoration-none">Writer: Paul Bowman</a></div>              </div>
              <div class="col mb-4 text-end social-icons">
                                <a class="btn btn-light btn-twitter" href="https://twitter.com/share?url=https%3A%2F%2Fwww.sportstalkphilly.com%2F2022%2F09%2Feagles-wentz-faceoff-goes-to-the-birds.html&title=Eagles-Wentz+Faceoff+Goes+To+The+Birds" target="_blank" rel="nofollow">
            <img width="16" height="17" src="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/icons/twitter-b.svg" alt="Twitter">
        </a>
        <a class="btn btn-light btn-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.sportstalkphilly.com%2F2022%2F09%2Feagles-wentz-faceoff-goes-to-the-birds.html&title=Eagles-Wentz+Faceoff+Goes+To+The+Birds" target="_blank" rel="nofollow">
            <img width="16" height="17" src="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/icons/facebook-b.svg" alt="Facebook">
        </a>
                <a class="btn btn-light btn-share addthis_button_expanded" href="" target="_blank" rel="nofollow">
            <span>Share</span>&nbsp;&nbsp;<img width="13" height="15" src="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/icons/share.svg">
        </a>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js"></script>
                  </div>
            </div>
                <div class="shadow-sm py-4 pe-4 mb-3 mb-lg-5 rounded">
                <div class="row big-author-box d-none d-lg-flex">
            <div class="col-3 text-center">
                <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=130&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=260&#038;d=mm&#038;r=g 2x' class='avatar avatar-130 photo' height='130' width='130' loading='lazy'/>                <div class="author-social">
                            <a href="https://twitter.com/PhillyBallPaul" rel="nofollow" target="_blank">
        <i class="fab fa-twitter"></i>
    </a>
                                </div>
            </div>
            <div class="col-9">
                <h4 class="author-name verified">
                Paul Bowman                </h4>
                <div class="author-desc mt-2 mb-3">
                    Penn State Great Valley MBA, Penn State Berks Undergrad, Eagle Scout and Vigil Honor, IT Service Manager. 
I joined Sports Talk Philly in 2017 and root for all the Philly teams (as well as their minor league counter parts).                </div>
                <div class="author-link d-none d-lg-block">
                    <a class="btn bg-info text-white" href="https://www.sportstalkphilly.com/author/paul-bowman">
                        View All Posts By Paul Bowman                    </a>
                </div>
            </div>
        </div>

        <div class="row big-author-box d-flex d-lg-none ms-2">
            <div class="col-3 text-center">
                <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=130&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=260&#038;d=mm&#038;r=g 2x' class='avatar avatar-130 photo' height='130' width='130' loading='lazy'/>            </div>
            <div class="col-9">
                <h4 class="author-name verified">
                Paul Bowman                </h4>
                <div class="author-social">
                            <a href="https://twitter.com/PhillyBallPaul" rel="nofollow" target="_blank">
        <i class="fab fa-twitter"></i>
    </a>
                                </div>
            </div>
            <div class="col-12 author-link text-center">
                <div class="author-desc mt-2 mb-3 text-start">
                    Penn State Great Valley MBA, Penn State Berks Undergrad, Eagle Scout and Vigil Honor, IT Service Manager. 
I joined Sports Talk Philly in 2017 and root for all the Philly teams (as well as their minor league counter parts).                </div>
                <a class="btn bg-info text-white" href="https://www.sportstalkphilly.com/author/paul-bowman">
                    View All Posts By Paul Bowman                </a>
            </div>

        </div>

              </div>

        </main> <!-- #main -->

      </div><!-- col -->
      <div class="col-xl-4 mt-4 mt-md-0 sidebar-area">
  <aside id="secondary" class="widget-area">
        
		<section id="recent-posts-3" class="widget widget_recent_entries card card-body mb-1 border-0">
		<h2 class="section-title mx-0">Latest News</h2>
		<ul>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/eagles-wentz-faceoff-goes-to-the-birds.html" aria-current="page">Eagles-Wentz Faceoff Goes To The Birds</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/eagles-commanders-preview.html">Eagles-Commanders Preview</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/cates-brothers-each-score-in-flyers-win-over-bruins.html">Cates Brothers Each Score in Flyers Win Over Bruins</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/flyers-bruins-preseason-game-1-preview.html">Flyers-Bruins: Preseason Game 1 Preview</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/flyers-camp-opens-with-abundance-of-injury-news.html">Flyers Camp Opens with Abundance of Injury News</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/tortorella-era-starts-as-flyers-training-camp-opens.html">Tortorella Era Starts as Flyers Training Camp Opens</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/plan-of-hope-already-backfires-on-flyers.html">Plan of Hope Already Backfires on Flyers</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/2022-phillies-rotational-obstacles.html">2022 Phillies: Rotational Obstacles</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/eagles-dominate-vikings-in-primetime.html">Eagles Dominate Vikings In Primetime</a>
									</li>
											<li>
					<a href="https://www.sportstalkphilly.com/2022/09/report-sean-couturier-to-miss-significant-time-with-back-injury.html">Report: Sean Couturier to Miss Significant Time with Back Injury</a>
									</li>
					</ul>

		</section>      </aside>
  <!-- #secondary -->
</div>    </div><!-- row -->

      <div class="fullwidth-block bg-light">
      
            <div class="widget widget_more_latest_news_block_widget">
            <h2 class="section-title">Related To Eagles</h2>
            <div class="row top-news more-news">
        
                    <div class="featured col-md-12 col-lg-6">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/eagles-wentz-faceoff-goes-to-the-birds.html">
                <img width="300" height="200" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1-300x200.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" srcset="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1-300x200.jpg 300w, https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1-768x512.jpg 768w, https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19115759_168396541_lowres-1.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h3 class="blog-post-title ">
                    <a href="https://www.sportstalkphilly.com/2022/09/eagles-wentz-faceoff-goes-to-the-birds.html">
                        Eagles-Wentz Faceoff Goes To The Birds                    </a>
                </h3>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/paul-bowman">Paul Bowman</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    12s                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

                        <div class="after-featured-wrap row col-sm-12 col-lg-6 mb-3">
                    <div class="after-featured not-featured col-sm-12 col-md-6">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/eagles-commanders-preview.html">
                <img width="150" height="150" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_17443965-2-150x150.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h5 class="blog-post-title m-heading-4">
                    <a href="https://www.sportstalkphilly.com/2022/09/eagles-commanders-preview.html">
                        Eagles-Commanders Preview                    </a>
                </h5>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/00d4f86588d92f684f240d971201ad48?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/00d4f86588d92f684f240d971201ad48?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/jennifer-mcgraw">Jennifer McGraw</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    16h                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

                <div class="after-featured not-featured col-sm-12 col-md-6">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/eagles-dominate-vikings-in-primetime.html">
                <img width="150" height="150" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19079571_168396541_lowres-1-150x150.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h5 class="blog-post-title m-heading-4">
                    <a href="https://www.sportstalkphilly.com/2022/09/eagles-dominate-vikings-in-primetime.html">
                        Eagles Dominate Vikings In Primetime                    </a>
                </h5>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/paul-bowman">Paul Bowman</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    Sep 19 2022                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

                    </div>
                <div class="not-featured col-sm-12 col-md-6 col-lg-3 mb-3">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/eagles-vikings-preview.html">
                <img width="150" height="150" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_18876494-2-150x150.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h5 class="blog-post-title m-heading-4">
                    <a href="https://www.sportstalkphilly.com/2022/09/eagles-vikings-preview.html">
                        Eagles-Vikings Preview                    </a>
                </h5>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/00d4f86588d92f684f240d971201ad48?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/00d4f86588d92f684f240d971201ad48?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/jennifer-mcgraw">Jennifer McGraw</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    Sep 18 2022                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

                <div class="not-featured col-sm-12 col-md-6 col-lg-3 mb-3">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/eagles.html">
                <img width="150" height="150" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_18771160_168396541_lowres-1-150x150.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h5 class="blog-post-title m-heading-4">
                    <a href="https://www.sportstalkphilly.com/2022/09/eagles.html">
                        Eagles Add Janarius Robinson in Wake of Barnett IR Placement                    </a>
                </h5>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/paul-bowman">Paul Bowman</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    Sep 13 2022                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

                <div class="not-featured col-sm-12 col-md-6 col-lg-3 mb-3">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/philadelphia-eagles-de-derek-barnett-tears-acl-done-for-the-season.html">
                <img width="150" height="150" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/My-project-18-150x150.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h5 class="blog-post-title m-heading-4">
                    <a href="https://www.sportstalkphilly.com/2022/09/philadelphia-eagles-de-derek-barnett-tears-acl-done-for-the-season.html">
                        Philadelphia Eagles DE Derek Barnett Tears ACL, Done for the Season                    </a>
                </h5>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/a2499657f087e5e871402e1737d49cc4?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a2499657f087e5e871402e1737d49cc4?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/michael-lipinski">Michael Lipinski</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    Sep 12 2022                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

                <div class="not-featured col-sm-12 col-md-6 col-lg-3 mb-3">
                    <div class="card h-100">
            <div class="card-image">
                <div class="category-badge"><a href="https://www.sportstalkphilly.com/eagles" class="badge bg-black text-white text-decoration-none">Eagles</a></div>                <a href="https://www.sportstalkphilly.com/2022/09/eagles-fly-away-with-win-over-lions.html">
                <img width="150" height="150" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/09/USATSI_19028259_168396541_lowres-1-150x150.jpg" class="card-img-top wp-post-image" alt="" loading="lazy" />                </a>
            </div>
            <div class="card-body d-flex flex-column">
                <h5 class="blog-post-title m-heading-4">
                    <a href="https://www.sportstalkphilly.com/2022/09/eagles-fly-away-with-win-over-lions.html">
                        Eagles Fly Away With Win Over Lions                    </a>
                </h5>

                <small class="text-muted">
                    <img alt='' src='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=20&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7fcae2bf602de232d9b81a435ae3b96?s=40&#038;d=mm&#038;r=g 2x' class='avatar avatar-20 photo' height='20' width='20' loading='lazy'/>                    <span class="author vcard"><a class="url fn n" href="https://www.sportstalkphilly.com/author/paul-bowman">Paul Bowman</a></span>                                    <span class="author dot">&nbsp;&bull;&nbsp;</span>
                    Sep 18 2022                                </small>

                
            </div><!-- card-body -->
        </div><!-- card -->

                </div>

        
            
            <a class="btn btn-info" href="https://www.sportstalkphilly.com/eagles">More Eagles News</a>
            </div>
        </div>              </div>


  </div><!-- #primary -->
</div><!-- #content -->


<footer>

  <div class="bootscore-footer">
	  <div class="container">
		  <div class="row">
			  <div class="bootscore-footer-logo col-12 col-md-3 text-md-start">
				 <div class="footer_widget mb-4"><img width="300" height="300" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/sports-talk-philly-logo-white-1.svg" class="image wp-image-23525  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></div>			  </div>
			  			  <div class="bootscore-footer-menu-wrap col-12 col-md-6">
				  <div class="footer_widget mb-4">			<div class="textwidget"><p><strong>DISCLAIMER</strong>: Gambling can be addictive, please play responsibly. If you or someone you know has a gambling problem and wants help, call 1-800 GAMBLER in the U.S. This service is intended for adult users only. Individuals must be 21+ to participate in sports betting and iGaming in the U.S.</p>
</div>
		</div>			  </div>
			  			  <div class="bootscore-footer-soc col-12 col-md-3">
				 <div class="widget_text footer_widget mb-4"><h2 class="widget-title h4">Follow Us</h2><div class="textwidget custom-html-widget"><ul class="bootscore-footer-soc-list mt-md-0">
                 <li><a href="https://twitter.com/sportstalkphl?lang=en" target="_blank" rel="noopener"><img width="24" height="25" src="https://www.sportstalkphilly.com/wp-content/uploads/2022/07/twitter.svg" alt="twitter" ></a></li>
              </ul></div></div>			  </div>
		  </div>
		
		  		  <div class="bootscore-info pt-2 pb-0 text-center">
			  
			  &copy;&nbsp; sportstalkphilly &#8211; News, rumors, game coverage of the Philadelphia Eagles, Philadelphia Phillies, Philadelphia Flyers, and Philadelphia 76ers. All Rights Reserved 2022		  </div>
	  </div>
  </div>

</footer>

<div class="top-button position-fixed zi-1020">
    <a href="#to-top" class="btn btn-to-top"><img width="24" height="24" src="https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/img/icons/arrow-up.svg"></a>
</div>


</div><!-- #page -->

<link rel='stylesheet' id='theme-override-css'  href='https://www.sportstalkphilly.com/wp-content/plugins/brand-managment/css/brand.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='slickcss-css'  href='https://www.sportstalkphilly.com/wp-content/plugins/brand-managment/css/slick.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='slickthemecss-css'  href='https://www.sportstalkphilly.com/wp-content/plugins/brand-managment/css/slick-theme.css?ver=6.0.1' type='text/css' media='all' />
<script type='text/javascript' id='load-more-js-extra'>
/* <![CDATA[ */
var load_more = {"ajaxurl":"https:\/\/www.sportstalkphilly.com\/wp-admin\/admin-ajax.php","posts":"null","nonce":"feeb2a8267"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/js/load-more.js?ver=1.0.0' id='load-more-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/plugins/finixio-mega-menu/assets/js/finixio-mega-menu-scripts.min.js?ver=10' id='finixio-mega-menu-scripts-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/js/slick.min.js?ver=6.0.1' id='slick-js-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/themes/bootscore-child-main/js/custom.js?ver=6.0.1' id='custom-js-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/themes/bootscore-main/js/lib/bootstrap.bundle.min.js?ver=202203151447' id='bootstrap-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/themes/bootscore-main/js/theme.js?ver=202203311206' id='bootscore-script-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/plugins/brand-managment/js/slick.js?ver=6.0.1' id='slickscript-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/plugins/brand-managment/js/slicklightbox.js?ver=6.0.1' id='slicklightboxscript-js'></script>
<script type='text/javascript' src='https://www.sportstalkphilly.com/wp-content/plugins/brand-managment/js/customscript.js?ver=6.0.1' id='brand_customscript-js'></script>

</body>

</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1664138062 -->